$re = '/(?=(?P<char>.))(?P=char){4,}/mi';
$str = 'ITS TIMEEEEEEEEE FOR ANNEW TRAILER FINALLY WE ARE GETTING SOMETHING';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);