$re = '/(?:\bfoo\((?=[^()]*\))|\G(?!^))[^\']*(?:\'\h*[,:]\h*)?\'\K\w+/m';
$str = 'foo(\'Alice\') -> Expected Hits: Alice
foo(\'Alice\', \'Bob\', \'Charlie\') -> Expected Hits: Alice, Bob, Charlie
foo(flag ? \'Alice\' : \'Bob\') -> Expected Hits: Alice, Bob';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);