import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/example\\.com$";
final String string = "<p>https://google.com</p>\n\n"
+ "<p>https://clankapp.com</p>\n\n"
+ "<p>https://yoyo.com</p>\n\n"
+ "<p>https://example.com</p>\n\n"
+ "https://example.com\n\n"
+ "<p>https://javascript.net/pizza</p>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}