const regex = /^https:\/\/example\.com$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/example\\.com$', 'gm')
const str = `<p>https://google.com</p>
<p>https://clankapp.com</p>
<p>https://yoyo.com</p>
<p>https://example.com</p>
https://example.com
<p>https://javascript.net/pizza</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}