re = /^https:\/\/example\.com$/m
str = '<p>https://google.com</p>
<p>https://clankapp.com</p>
<p>https://yoyo.com</p>
<p>https://example.com</p>
https://example.com
<p>https://javascript.net/pizza</p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end