// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/example\.com$").unwrap();
let string = "<p>https://google.com</p>
<p>https://clankapp.com</p>
<p>https://yoyo.com</p>
<p>https://example.com</p>
https://example.com
<p>https://javascript.net/pizza</p>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}