const regex = new RegExp('(?<!\\d)-(?=\\d)', 'gm')
const str = `7+6+-7
6 - -12
-12 - -11
1--2
-1--2
4*-5
-4/-4`;
const subst = `~`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);