$re = '/(?<!\d)-(?=\d)/m';
$str = '7+6+-7
6 - -12
-12 - -11
1--2
-1--2
4*-5
-4/-4';
$subst = "~";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;