import re
regex = re.compile(r"(?<!\d)-(?=\d)", flags=re.MULTILINE)
test_str = ("7+6+-7\n"
"6 - -12\n"
"-12 - -11\n"
"1--2\n"
"-1--2\n"
"4*-5\n"
"-4/-4")
subst = "~"
result = regex.sub(subst, test_str)
if result:
print(result)