re = /(?<!\d)-(?=\d)/m
str = '7+6+-7
6 - -12
-12 - -11
1--2
-1--2
4*-5
-4/-4'
subst = '~'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result