re = /^[sS]ee, e\.g\.,(?![^()\n]*(?=\()(\(1st Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(2nd Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(3rd Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(4th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(5th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(6th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(7th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(8th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(9th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(10th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(11th Cir\. \d{4}\))?[^()\n]*(?=\(|\.)(\(D\.C\. Cir\. \d{4}\))?\.?$).*/m
str = 'See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (3rd Cir. 2017).
See, e.g., Jefferson v. U.S. (2nd Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).
See, e.g., Lincoln v. Jones (3rd Cir. 2012); U.S. v. Roosevelt (5th Cir. 2017).
See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).
See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).
See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end