$re = '/(?<=-)[^-@\s]+(?=@)/m';
$str = '7bb19406-f97a-47b3-b42c-40868d2cef5b-1661496224@example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);