using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)#\w*[a-zA-Z]\w*";
string input = @"#1234abc
: Should get matched
#abc123
: Should get matched
#123abc123
: Should get matched
#123
: Should not get matched
#123_
: Should not get matched
#123abc_
: Should get matched";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}