const regex = new RegExp('((?<=<q>)(.|\\n|\\s)*?(?=</q>))|((?<=<t>)(.|\\n|\\s)*?(?=</t>))', 'gm')
const str = `<q>123e42wfd</q>
<p> Праздничную иллюминацию в Липецке прежде традиционно отключали 15 января. Однако в этом году она будет работать до конца месяца, соответственно дольше обычного жители областного центра смогут любоваться световыми арт-объектами и нарядными новогодними елками.
Такое решение принял глава города Сергей Иванов.Как сообщил председатель департамента дорожного хозяйства и благоустройства Алексей Бахтин, идея навеяна самой нынешней зимой. Яркие краски светового оформления города подчеркнут красоту заснеженных улиц и продлят праздничное настроение липчанам. </p>
<t> В администрации Липецка - незаурядная отставка: уходит управделами Виктор Ивлев, житель Тербунов, которого в мэрию привел его земляк Сергей Иванов, ставший главой города волей Липецкого горсовета в декабре 2015 года. Последним местом работы Виктора Ивлева в Тербунах была должность председателя районной территориальной избирательной комиссии.- 14 января станет последним днем работы Виктора Денисовича. Он принял такое решение по состоянию здоровья. Недавно он перенес тяжелую операцию на сердце и решил уйти с должности на пенсию, - прокомментировал GOROD48 циркулирующие слухи об отставке управделами мэрии глава Липецка Сергей Иванов. </t>
(?<=<title>)(.*)(?=</title>)
<t> В администрации Липецка - незаурядная отставка: уходит управделами Виктор Ивлев, житель Тербунов, которого в мэрию привел его земляк Сергей Иванов, ставший главой города волей Липецкого горсовета в декабре 2015 года. Последним местом работы Виктора Ивлева в Тербунах была должность председателя районной территориальной избирательной комиссии.- 14 января станет последним днем работы Виктора Денисовича. Он принял такое решение по состоянию </t>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}