#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^ # Start of string" & @CRLF & _
"\#? # Optional "#"" & @CRLF & _
"[a-z]{4} # Followed by 4 letters" & @CRLF & _
"\ ? # Optional space" & @CRLF & _
"_ # Followed by an underscore" & @CRLF & _
"[ ]? # Optional space" & @CRLF & _
"[0-9]{6} # Followed by 6 digits" & @CRLF & _
"[#]? # Optional "#"" & @CRLF & _
"$ # End of string"
Local $sString = "abcd_123456" & @CRLF & _
"abcd _ 123456" & @CRLF & _
"#abcd_123456" & @CRLF & _
"abcd_123456#" & @CRLF & _
"#abcd_123456#" & @CRLF & _
"#abcd _ 123456#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")