use strict;
my $str = 'abcd_123456
abcd _ 123456
#abcd_123456
abcd_123456#
#abcd_123456#
#abcd _ 123456#';
my $regex = qr/^ # Start of string
\#? # Optional "#"
[a-z]{4} # Followed by 4 letters
\ ? # Optional space
_ # Followed by an underscore
[ ]? # Optional space
[0-9]{6} # Followed by 6 digits
[#]? # Optional "#"
$ # End of string/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}