using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[^']*'(*SKIP)(*F)|[^'\s]*(\s{2,})[^'\s]*";
string input = @"update tabela set
nome='alberto da silva',
telefone='1234'
)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}