package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'[^']*'(*SKIP)(*F)|[^'\s]*(\s{2,})[^'\s]*`)
var str = `update tabela set
nome='alberto da silva',
telefone='1234'
)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}