re = /'[^']*'(*SKIP)(*F)|[^'\s]*(\s{2,})[^'\s]*/m
str = 'update tabela set
nome=\'alberto da silva\',
telefone=\'1234\'
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end