package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z](?:[a-zA-Z0-9.-]{0,22}[a-zA-Z0-9])?$`)
var str = `a12345678901234567891234
a1234567890123456789123-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}