#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?msi)(?smi)^.*tag="[A-Z]_([A-Z]{2})_(\d{4}).*$"
Local $sString = "<?xml version="1.0"?>" & @CRLF & _
"-<PEGraphic gridSpaceY="100" gridSpaceX="100" bkgdImage="" gridColor="#333333" paperColor="#000000" width="19600" height="14200" version="5">" & @CRLF & _
"<Font height="120" name="Arial"/>" & @CRLF & _
"-<Polyline backFill="yes" backColor="#FFFFFF">" & @CRLF & _
"<Location right="6020" bottom="12445" left="6018" top="11741"/>" & @CRLF & _
"<Pen width="2" style="solid" color="#00FF00"/>" & @CRLF & _
"<Brush style="hollow" color="#00FF00"/>" & @CRLF & _
"<Point y="11741" x="6019"/>" & @CRLF & _
"<Point y="12445" x="6019"/>" & @CRLF & _
"</Polyline>" & @CRLF & _
"-<Polyline backFill="yes" backColor="#E0E0E0">" & @CRLF & _
"<Location right="3365" bottom="12835" left="3363" top="11741"/>" & @CRLF & _
"<Pen width="2" style="solid" color="#00FF00"/>" & @CRLF & _
"<Brush style="hollow" color="#00FF00"/>" & @CRLF & _
"<Point y="11741" x="3364"/>" & @CRLF & _
"<Point y="12835" x="3364"/>" & @CRLF & _
"</Polyline>" & @CRLF & _
"-<Polyline backFill="yes" backColor="#FFFFFF">" & @CRLF & _
"<Location right="4627" bottom="6800" left="4521" top="5100"/>" & @CRLF & _
"<Pen width="2" style="solid" color="#00FF00"/>" & @CRLF & _
"<Brush style="hollow" color="#00FF00"/>" & @CRLF & _
"<Datasource stepped="no" server="USFRPVMESPOLYOL" map="IP_DIMAP" field="VAL" tag="p_dc_1730"/>" & @CRLF & _
"-<Animation on="yes">" & @CRLF & _
"<AnimationRange color="#666666" image="" text="act sp" max="0" min="0" index="1"/>" & @CRLF & _
"<AnimationRange color="#00FF00" image="" text="act sp" max="1" min="1" index="2"/>" & @CRLF & _
"</Animation>" & @CRLF & _
"<Point y="5100" x="4627"/>" & @CRLF & _
"<Point y="6800" x="4627"/>" & @CRLF & _
"</Polyline>" & @CRLF & _
"-<Polyline backFill="yes" backColor="#FFFFFF">" & @CRLF & _
"<Location right="3719" bottom="4394" left="1918" top="3300"/>" & @CRLF & _
"<Pen width="2" style="solid" color="#00FF00"/>" & @CRLF & _
"<Brush style="hollow" color="#00FF00"/>" & @CRLF & _
"<Datasource stepped="no" server="USFRPVMESPOLYOL" map="" field="VAL" tag="P_DC_2103"/>" & @CRLF & _
"-<Animation on="yes">" & @CRLF & _
"<AnimationRange color="#666666" image="" text="act sp" max="0" min="0" index="1"/>" & @CRLF & _
"<AnimationRange color="#00FF00" image="" text="act sp" max="1" min="1" index="2"/>" & @CRLF & _
"</Animation>" & @CRLF & _
"<Point y="4394" x="3718"/>" & @CRLF & _
"<Point y="4098" x="3718"/>" & @CRLF & _
"<Point y="4098" x="1918"/>" & @CRLF & _
"<Point y="3300" x="1918"/>" & @CRLF & _
"</Polyline>" & @CRLF & _
""
Local $sSubst = "CG $1($2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)