package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(zn|zr|zt|zs)[a-km-zA-HJ-NP-Z1-9]{25,34}$`)
var str = `znUovxhrE91tep6D7YtgSc3XJZoYQLVDwVn
zszpcLB6C5B8QvfDbF2dYWXsrpac5DL9WRk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}