const regex = /^(zn|zr|zt|zs)[a-km-zA-HJ-NP-Z1-9]{25,34}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(zn|zr|zt|zs)[a-km-zA-HJ-NP-Z1-9]{25,34}$', 'gm')
const str = `znUovxhrE91tep6D7YtgSc3XJZoYQLVDwVn
zszpcLB6C5B8QvfDbF2dYWXsrpac5DL9WRk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}