re = /(\S+)\s\1/
str = 'Deep episodes of Deep Space Nine came on the television only after the news.
Digital alarm clocks scare area children '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end