#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[\w-]\.?)+)@((?:[\w-]+\.)+)([A-Za-z]{2,4})"
Local $sString = "donkey.kong@kart.com.br" & @CRLF & _
"bowser1@games.info " & @CRLF & _
"super-mario@nintendo.JP" & @CRLF & _
"TEAM.donkey-kong@MARIO.kart1.nintendo.com" & @CRLF & _
"" & @CRLF & _
"toad@kart...com" & @CRLF & _
"wario@kart@nintendo.com" & @CRLF & _
"yoshi@nintendo" & @CRLF & _
"daisy@nintendo.b" & @CRLF & _
"..@email.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")