Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^((?:[\w-]\.?)+)@((?:[\w-]+\.)+)([A-Za-z]{2,4})
/
gm
Input 1
1
New
donkey.kong@kart.com.br bowser1@games.info super-mario@nintendo.JP TEAM.donkey-kong@MARIO.kart1.nintendo.com toad@kart...com wario@kart@nintendo.com yoshi@nintendo daisy@nintendo.b ..@email.com