re = /^((?:[\w-]\.?)+)@((?:[\w-]+\.)+)([A-Za-z]{2,4})/m
str = 'donkey.kong@kart.com.br
bowser1@games.info
super-mario@nintendo.JP
TEAM.donkey-kong@MARIO.kart1.nintendo.com
toad@kart...com
wario@kart@nintendo.com
yoshi@nintendo
daisy@nintendo.b
..@email.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end