#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x)^" & @CRLF & _
"([\d-]+)\s+([\d:.]+)\s+" & @CRLF & _
"(\d+)\s\s(\d+)\s" & @CRLF & _
"([VDIWEF])\s(.*?):" & @CRLF & _
"(.*)" & @CRLF & _
"$"
Local $sString = "06-09 17:48:08.555 1644 5345 V EXAPLE_TAG: hello I am a log1" & @CRLF & _
"06-09 17:48:08.555 1644 5345 D EXAPLE_TAG: hello I am a log2" & @CRLF & _
"06-09 17:48:08.555 1644 5345 I EXAPLE_TAG: hello I am a log3" & @CRLF & _
"06-09 17:48:08.555 1644 5345 W EXAPLE_TAG: hello I am a log4" & @CRLF & _
"06-09 17:48:08.555 1644 5345 E EXAPLE_TAG: hello I am a log5" & @CRLF & _
"06-09 17:48:08.555 1644 5345 F EXAPLE_TAG: hello I am a log6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")