use strict;
my $str = '06-09 17:48:08.555 1644 5345 V EXAPLE_TAG: hello I am a log1
06-09 17:48:08.555 1644 5345 D EXAPLE_TAG: hello I am a log2
06-09 17:48:08.555 1644 5345 I EXAPLE_TAG: hello I am a log3
06-09 17:48:08.555 1644 5345 W EXAPLE_TAG: hello I am a log4
06-09 17:48:08.555 1644 5345 E EXAPLE_TAG: hello I am a log5
06-09 17:48:08.555 1644 5345 F EXAPLE_TAG: hello I am a log6';
my $regex = qr/(?x)^
([\d-]+)\s+([\d:.]+)\s+
(\d+)\s\s(\d+)\s
([VDIWEF])\s(.*?):
(.*)
$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}