// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)(?x)^
([\d-]+)\s+([\d:.]+)\s+
(\d+)\s\s(\d+)\s
([VDIWEF])\s(.*?):
(.*)
$").unwrap();
  let string = "06-09 17:48:08.555  1644  5345 V EXAPLE_TAG: hello I am a log1
06-09 17:48:08.555  1644  5345 D EXAPLE_TAG: hello I am a log2
06-09 17:48:08.555  1644  5345 I EXAPLE_TAG: hello I am a log3
06-09 17:48:08.555  1644  5345 W EXAPLE_TAG: hello I am a log4
06-09 17:48:08.555  1644  5345 E EXAPLE_TAG: hello I am a log5
06-09 17:48:08.555  1644  5345 F EXAPLE_TAG: hello I am a log6";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}