#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<!-- OPTIONAL -->(.*?)<!-- OPTIONAL END -->"
Local $sString = "<p>something</p>" & @CRLF & _
"" & @CRLF & _
"<!-- OPTIONAL -->" & @CRLF & _
"" & @CRLF & _
"<p class="sdf"> some text</p>" & @CRLF & _
"<p> some other text</p>" & @CRLF & _
"" & @CRLF & _
"<!-- OPTIONAL END -->" & @CRLF & _
"" & @CRLF & _
"<p>The end</p>" & @CRLF & _
"" & @CRLF & _
"<p>something</p>" & @CRLF & _
"" & @CRLF & _
"<!-- OPTIONAL -->" & @CRLF & _
"" & @CRLF & _
"<p class="sdf"> some text</p>" & @CRLF & _
"<p> some other text</p>" & @CRLF & _
"" & @CRLF & _
"<!-- OPTIONAL END -->" & @CRLF & _
"" & @CRLF & _
"<p>The end</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")