$re = '/([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[0-9]{2})|([0-9]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{1})|([0-9]{1}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})|([a-b-d-p-r-z-A-B-D-P-R-Z]{1}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})($|\ |\.|\,|\;|\r|\n|\r\n|\t) 
/';
$str = 'ab-23-23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);