use strict;
my $str = 'I need a RegEx to match the following condition:
1 or 2 words
Total minimum length is 3
Total maximum length is 50
Accept accented characters
No numbers is a plus
Examples of accepted strings: dfg dfg dfg sdfg dasfg
Karmen Garcia
João Pedro
Vitor
maxiliamum Lófffffffffffffffffffffffffffffffffffff
Nadál
loriPsium PsisVõèrbizbbbbbbbbbb
Examples of non accepted string:
Jony Cam Vanis
kljsdfklsdfkljsfkldsfkljs dsfkljsdlfldjsfkldjsfljsdlkfjls
sdlfkjsdklfjklsdfjkljsfjsdfljsdlfjsdfkljsdfkljsdlfkjlksf
9lucas P.us-kas1 Li1
What I tried:
^(?!.*?\\s{2})[A-Za-z ]{3,50}$
^([a-zA-Z][a-zA-Z]){3,50}$';
my $regex = qr/^(?=.{3,50}$)[^\s\d]*(\s[^\s\d]*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}