$re = '~\b(\w+)\b\s*[-+/*]\s*PrevYear\s*\1\b~m';
$str = 'Position_Name + PrevYear Position_Name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);