re = /\s-\s|[(),\s]/m
str = 'T1 - X1(1), 7
T2 - C2(-9), -15
T3 - Y2(1), 3
T5 - C2(-1), 100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end