package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)http://139.155.123.45:8001/app/sys/console/index.tfp
https:scontentxxfbcdnnethads-ak-prn21487645_6012475414660_1439393861_npng
`)
var str = `
us1.getyooz.com
const audioContext = new (window.AudioContext || window.webkitAudioContext)();
const oscillator = audioContext.createOscillator();
oscillator.frequency.setValueAtTime(440, audioContext.currentTime); // A4 note
oscillator.connect(audioContext.destination);
oscillator.start();
oscillator.stop(audioContext.currentTime + 2);
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}