const regex = /\d{4}-\d{2}-\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{4}-\\d{2}-\\d{2}', 'gm')
const str = `2021-12-07
2022-01-01
2021/01/01
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}