#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?<!!)[A-Z]{1,2}[0-9]"
Local $sString = "=+(sheet_factory_costs!A17/sheet_employees!D23)+T12+W12" & @CRLF & _
"=+(sheet_factory_costs!A17 / sheet_employees!D23)+sheet_turnover!T12+sheet_turnover!W12"
Local $sSubst = "sheet_turnover!$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)