import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span[^>]+class=\"[^\"]*\\btxt_arial_8pt_black\\b[^\"]*\"[^>]*>(.*)</span>";
final String string = "<span class=\"txt_arial_8pt_black\">Antes <span>Durante</span> Depois</span>\n"
+ "<span class=\"txt_arial_8pt_black\">outro</span><br>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}