re = /^(\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/)(.*)$/m
str = '/testNAS/questions/ask/test/example/picture.png'
subst = '$1;$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result