#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Za-z]{2,4})([a-zA-Z0-9\-\_ ]{2,12})"
Local $sString = "IT12345678901" & @CRLF & _
"NL123456789B01" & @CRLF & _
"ESX1234567X" & @CRLF & _
"ATUU12345678" & @CRLF & _
"FI1234567-9" & @CRLF & _
"HU 12345678" & @CRLF & _
"DE_123456789" & @CRLF & _
"AAAAAAAAAAA" & @CRLF & _
"AAA aaaaaa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")