using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z]{2,4})([a-zA-Z0-9\-\_ ]{2,12})";
string input = @"IT12345678901
NL123456789B01
ESX1234567X
ATUU12345678
FI1234567-9
HU 12345678
DE_123456789
AAAAAAAAAAA
AAA aaaaaa
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}