# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-Za-z]{2,4})([a-zA-Z0-9\-\_ ]{2,12})"
test_str = ("IT12345678901\n"
"NL123456789B01\n"
"ESX1234567X\n"
"ATUU12345678\n"
"FI1234567-9\n"
"HU 12345678\n"
"DE_123456789\n"
"AAAAAAAAAAA\n"
"AAA aaaaaa\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.