package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^\|]+\|){0}([^\|]+)`)
var str = `astring| another string|test|maybe some more text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}