const regex = new RegExp('^([^a-zA-Z\\d])?(?P<file_id>[\\-a-zA-Z]{3}[\\-a-zA-Z\\d]{5,15}H?)([^a-zA-Z\\d].*)?\\.(?P<file_ext>mov|mpg|mxf|mp4)$', 'gm')
const str = `GOOG6998000H.mov`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}