use strict;
my $str = 'GOOG6998000H.mov';
my $regex = qr/^([^a-zA-Z\d])?(?P<file_id>[\-a-zA-Z]{3}[\-a-zA-Z\d]{5,15}H?)([^a-zA-Z\d].*)?\.(?P<file_ext>mov|mpg|mxf|mp4)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}