using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,2}\.\d{2}\.\d{4}-\d{2}\.\d{2}\.\d{4}$";
string input = @"23.04.2019-30.04.2019
3.06.2019-20.06.2019";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}