// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,2}\.\d{2}\.\d{4}-\d{2}\.\d{2}\.\d{4}$").unwrap();
let string = "23.04.2019-30.04.2019
3.06.2019-20.06.2019";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}