import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\t+)(.+\\|)(\\n)((\\1\\t)(.+)(\\n)+)+";
final String string = " win_shell: |\n"
+ " Move-Item -Path \"C:\\OldPath\\*.dat\" -Destination \"C:\\NewPath\\\"\n"
+ " info\n"
+ " info\n\n"
+ " info\n"
+ " some info\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}