use strict;
my $str = ' win_shell: |
Move-Item -Path "C:\\OldPath\\*.dat" -Destination "C:\\NewPath\\"
info
info
info
some info
';
my $regex = qr/(\t+)(.+\|)(\n)((\1\t)(.+)(\n)+)+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";